Removing comma in results


#1

I have large data sets of results that I often like to copy and paste data out of. With the comma included in large number fields I am forced to go through and clean this data before searching. Is there a way to remove comma’s in table results?


#2

Same request here


#3

Hi, when you use SQL syntax to create you questions you could just use the syntax concat(field) for every field. It will create a text 123456 instead of the number 123,456, maybe that is what you need?
Cheers, Eva


#4

@EvaS brilliant! Thank you :man_dancing:


#5

I think the appropriate New Feature issue that this could fall under is: (which you can :+1: vote for)

Until it can float to the top of a list - it’s good @EvaS SQL workaround is there!


#6

I stumbled across another workaround for data in a table (not tested on anything else).
Remove all your groups so that all you see is a single number.
In settings, you’re now able to change the number formatting:
image
Change so that there are no separators.
Now add your groups back.
The table will still show the commas:
image
but they’re not in the csv export:
image

Strange, but true.