[SOLVED] Not able to test send an e-mail while I am creating a Pulse


#1

I am creating a new Pulse but when I hit the “Send email now” button, is errors out “Sending Failed” and I have the following error in the server log:

09-04 11:57:51 ^[[1mERROR metabase.middleware^[[0m :: ^[[31mPOST /api/pulse/test 500 (57 ms) (13 DB calls).^[[0m
{:message “Don’t know how to create ISeq from: metabase.pulse.render$section_style”,
:type java.lang.IllegalArgumentException,
:stacktrace
[“pulse.render$style.invokeStatic(render.clj:140)”
“pulse.render$style.doInvoke(render.clj:135)”
“email.messages$pulse_context.invokeStatic(messages.clj:239)”
“email.messages$pulse_context.invoke(messages.clj:236)”
“email.messages$render_pulse_email.invokeStatic(messages.clj:291)”
“email.messages$render_pulse_email.invoke(messages.clj:288)”
“pulse$fn__33588.invokeStatic(pulse.clj:159)”
“pulse$fn__33588.invoke(pulse.clj:150)”
“pulse$pulse__GT_notifications$iter__33655__33659$fn__33660$fn__33661.invoke(pulse.clj:230)”
“pulse$pulse__GT_notifications$iter__33655__33659$fn__33660.invoke(pulse.clj:228)”
“pulse$send_notifications_BANG_.invokeStatic(pulse.clj:214)”
“pulse$send_notifications_BANG_.invoke(pulse.clj:213)”
“pulse$send_pulse_BANG_.invokeStatic(pulse.clj:241)”
“pulse$send_pulse_BANG_.doInvoke(pulse.clj:232)”
“api.pulse$fn__33795$fn__33798.invoke(pulse.clj:156)”
“api.common.internal$do_with_caught_api_exceptions.invokeStatic(internal.clj:254)”
“api.common.internal$do_with_caught_api_exceptions.invoke(internal.clj:249)”
“api.pulse$fn__33795.invokeStatic(pulse.clj:148)”
“api.pulse$fn__33795.invoke(pulse.clj:148)”
“middleware$enforce_authentication$fn__32147.invoke(middleware.clj:117)”
“api.routes$fn__48537.invokeStatic(routes.clj:82)”
“api.routes$fn__48537.invoke(routes.clj:82)”
“routes$fn__49305$fn__49306.doInvoke(routes.clj:108)”
“routes$fn__49305.invokeStatic(routes.clj:103)”
“routes$fn__49305.invoke(routes.clj:103)”
“middleware$log_api_call$fn__32246$fn__32248.invoke(middleware.clj:347)”
“middleware$log_api_call$fn__32246.invoke(middleware.clj:346)”
“middleware$add_security_headers$fn__32196.invoke(middleware.clj:249)”
“core$wrap_streamed_json_response$fn__50100.invoke(core.clj:67)”
“middleware$bind_current_user$fn__32151.invoke(middleware.clj:138)”
“middleware$maybe_set_site_url$fn__32200.invoke(middleware.clj:273)”]}

Any idea?


#2

I tried reproducing your problem but was not able to, so I basically just wasted my time.

I don’t know what version of Metabase you are on, I don’t know what steps you took to get this error …

In general when asking for help when you experience an error it’s a good idea to provide some info like Please read me before reporting a bug! suggests.


#3

Thanks for educated me. I checked the reported bugs but I couldn’t find some equal to my error message. Follow below more details:

Metabase Hosting OS: Oracle Linux Server release 7.3
Client OS: Windows 10 (64 bits)
Browser version: Chrome 69.0.3497.81 (Official Build) (64-bit)
Metabase DB: H2
Metabase Version: 0.28.5
Metabse database which I am connecting to: Oracle 12c

Repeatable steps to reproduce the issue:
In the Admin panel, Email settings I have the following configuration:
SMTP HOST: mysmtpserver.com
SMTP PORT: 25
SMTP SECURITY: None
SMTP USERNAME: (leave in blank)
SMTP PASSWORD: (leave in blank)
FROM ADDRESS: Metabase_DEV@Mycompany.com

Here if I click in Sent test e-mail, it works OK

Now, when I am setting a new pulse, I set the To: to my user but when I click in the "Send email now” button, is errors out “Sending Failed” and I see the log reported above.


#4

Appreciate you’re getting back with such a clear description. Now I don’t think I wasted my time any more :slightly_smiling_face:

I checked the changes to source since v0.28.5 but didn’t see any smoking gun with exactly the error you experience fixed. I did however see changes go into version 0.29 regarding rendering of pulses which is part of the error you get:

Also since I have it working with v0.30 I suggest you try upgrading and see if it fixes the bug.


#5

After upgrade to the latest version, this issue has gone. Tks.