SQL SSL Connection Error after updated to latest version


#1

Hello guys,
We’ve been using an old version of Metabase via Docker and everything was working perfectly, before the upgrade.
When we upgraded to latest version, we cannot connect to our SQL server anymore. The log file shows this error:

12-21 14:51:53 ERROR metabase.driver :: Failed to connect to database: com.microsoft.sqlserver.jdbc.SQLServerException: The driver could not establish a secure connection to SQL Server by using Secure Sockets Layer (SSL) encryption. Error: “sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target”. ClientConnectionId:b0b816e3-663a-442b-9d47-b22dc6c2e14f

12-21 14:51:53 ERROR metabase.driver :: Failed to connect to database: com.microsoft.sqlserver.jdbc.SQLServerException: Login failed for user ‘XXXXXXXXXXX’. ClientConnectionId:898cf362-0a87-448f-a889-a82d630ff155

We find out that JDBC driver is updated and the driver is trying to connect only with SSL Connection:
The v1.2 driver ALWAYS uses SSL to encrypt the login to SQL Server. You cannot disable SSL encryption of the SQL Server login. (references:https://blogs.msdn.microsoft.com/jdbcteam/2008/09/09/the-driver-could-not-establish-a-secure-connection-to-sql-server-by-using-secure-sockets-layer-ssl-encryption/ )

We tried with latest .jar file too, but its the same error.
Please help us!


#2

I’ve the same issue.
Since the 0.26.0 release, a new SQL Microsoft JDBC driver (#5491) is used.
All connections parameters that worked on the old driver (before release 0.26) no longer work now on this new driver.

As the latest JDBC Driver doesn’t allow to disable SSL, i’m afraid at the moment and without a new way in Metabase, no solution exists to connect Metabase without SSL on MSSQL.

You can check this page to follow discussions around new JDBC driver.