Accessing Metabase Public Dashboard Failing on Elastic BeanStalk

I have successfully deployed Metabase using Docker platform on Elastic BeanStalk. After creating a dashboard, I am trying to deploy it to the public. So, the public dashboard link is available with the IP address and then the usual sub-link:
when I click on it, a tab opens but it keeps going round and round. The dashboard never shows up. I tried changing the EC2 or the environment’s inbound rule to allow everything, but that still didn’t work. Can someone please help me?
Oh, the nginx log says connection refused.

Hi @ajaygshah
Make sure that the Site URL in Admin > Settings > General is setup as the actual address Metabase is on. So if you have added load balancers and a domain, then address needs to be that. Remember the difference between http and https.

1 Like

Thank you so much! That worked. :slight_smile:
Yes, I am just in testing mode at this point for my organisation, so I am ok with HTTP but you’re right. Thank you again.