Additional JDBC option failed

Hi,

We’re using Metabase in our firm and we’re facing an issue when we try to connect a DB with some additional JDBC connection string options.

We want to read the data on another database instance so we need to add some additionnal options in which one of them doesn’t work : ApplicationIntent = ReadOnly.

We get this error : Timed out after 5000 milliseconds, and nothing in logs.

Can somebody help us ?

Hi @KentVchr
Which version of Metabase? Please post “Diagnostic Info” from Admin > Troubleshooting
Which database+version are you trying to add the parameters to?
I’m fairly sure that the spaces are probably causing some of the problem. Connection strings are very strict, so just one character off can mess it up.

Hi @flamber
We’re trying to add the option on a SQL Server database. And we have the same problem without spaces.
Here is the diagnostic infos :

{
“browser-info”: {
“language”: “fr-FR”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.130 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “1.8.0_191-b12”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “http://java.oracle.com/”,
“java.version”: “1.8.0_191”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “25.191-b12”,
“os.name”: “Linux”,
“os.version”: “3.10.0-957.21.2.el7.x86_64”,
“user.language”: “fr”,
“user.timezone”: “Europe/Paris”
},
“metabase-info”: {
“databases”: [
“sqlserver”,
“mysql”,
“h2”
],
“hosting-env”: “unknown”,
“application-database”: “postgres”,
“run-mode”: “prod”,
“version”: {
“tag”: “v0.34.1”,
“date”: “2020-01-13”,
“branch”: “release-0.34.x”,
“hash”: “265695c”
},
“settings”: {
“report-timezone”: “Europe/Brussels”
}
}
}

@KentVchr Seems like a known issue with the driver:
https://stackoverflow.com/questions/38356460/sql-server-application-intent-not-working-jdbc
https://github.com/microsoft/mssql-jdbc/issues/484
https://docs.microsoft.com/en-us/sql/connect/jdbc/setting-the-connection-properties
Have you tried other JDBC clients to see if the problem is specific to Metabase or generally with the JDBC driver?