Bigquery timed out

A query that takes more than 2 minutes with bigquery will timed out. What should I do now?
I use managed metabase of starter plan.

  "browser-info": {
    "language": "ja-JP",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.10+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.10",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.10+9",
    "": "Linux",
    "os.version": "4.14.219-164.354.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.7"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.18"
    "run-mode": "prod",
    "version": {
      "date": "2021-04-08",
      "tag": "v1.38.4",
      "branch": "release-x.38.x",
      "hash": "057b6bb"
    "settings": {
      "report-timezone": null

Hi @hs7
So it sounds like you're one of the few people who are actually hitting this issue:
Currently there's no workaround in Metabase for that - only that you optimize the query, so it runs faster.

Hi @flamber
Thank you for your quick reply. All right.