Broken variable after changes in BigQuery

Hi !

It think there might be a bug when I want to use a variable that has being modified in BigQuery.

For a few weeks, I have being using a table and its variables without any trouble. I even created several dashboards with different categories where I could link a variable from a question to a filter.

Capture d’écran 2021-09-15 à 10.05.01
What happened, is that after changing a variable (added 20 different values and ended with total 50 different values) in a table coming from BigQuery, this variable stopped appearing when I would try to link it to as a filter on my dashboard in Metabase even though I could do it before. Weirdly, I can use it when need it in a "group by".

However if I change the name of my table in BigQuery and wait for it to appear in Metabase, I could use the same variable without any trouble. I suppose if I delete my table in BiQuery and wait for it to disappear in Metabase and then upload again I might not have this issue.

While this may be a temporary fix on our side, this might become very quickly tiresome if I end up having my dashboards down between 1 to 2 hours after I made some modifications.

Just a side note, when I was looking for a solution, I tried with the help of the integrator to just delete the table (and also get rid of the cache) and reuploaded to fix this issue, but it did nothing.

So, I want to know if there is a quicker solution on my side each time I find myself with this issue or it it's a bug in Metabase and you might be able to fix it.

Thank you and have a nice day !

Hi @aterrien
Metabase only syncs your database every hour, so you'll need to manually sync if you make changes to your database structure.
Admin > Databases > (db) > Sync database schema now - you can follow the progress in Admin > Troubleshooting > Logs.

Thank you very much for your super fast answer ! I transfered your answer to my administrator. I will tell you once I have him to see if it worked.