Cannot open a SQL Server database on Azure

We’re running metabase on AWS Elastic Beanstalk.

When attempting to setup our production MS SQL Server running on Azure I get the following:

java.sql.SQLException: Cannot open database ‘’ on server ‘’ requested by the login. Access to the database is only allowed using a security-enabled connection string.

I can connect with the same settings in SQL Server Management Studio.

Any idea what could be the problem?

Try pulling down a jar or the mac app and trying to connect to the database from the same IP you’re using for SQL Server management studio.

If that works, then it’s probably a network connectivity/firewall issue. If that doesn’t work, let us know, as it might be a specific connection string or driver setting you need.

Same issue trying to connect from the mac app.

Hmm… can you share versions of MB, SQL Server and the authentication scheme SQL server is using?

Sure.

metabase v0.22.0
azure sql server V12 (Standard S3 edition if that matters)
sql server connections only.

Try using .database.secure.windows.net

That should get past your particular message, however I have not been able to successfully connect to an azure db. This is what happens next:

java.sql.SQLException: I/O Error: DB server closed connection.

Let me know if you have any further luck, would love to get this to work.

I tried that as well and saw the same error message.

I wonder if this is the solution:

ssl=require is at least mentioned in the code here:

Never used clojure so I can’t really debug it though :frowning: