Can't add a new database (Timed Out)

Hi! I've recently been trying to learn how to use metabase since im quite new to this topic. For some days now i have been trying to setup a new database so i can fidget around with settings and get to know the platform better. But everytime I try to add a database (MSSQL database) an error with the message "Timed Out 10,0s" keeps appearing.
I've tryed following other answers on this forum but none have worked.
Database name is blurred out for privacy reasons.

Hi there,

I had the same issue with adding a MSSQL server to Metabase.
In my case the issue was the port number and some other settings in the sql server configuration manager.

Make sure that under the SQL Server Netwerk configuration protocols, Named Pipes & TCP/IP is enabled.
Then under the TCP/IP protocol window, under the tab 'IP ADRESSES", scroll down to the bottom under the section IPALL and check if TCP port is put to 1433.
You can remove the value (if there is any) under TCP Dynamic Ports.

This made it work for me.

If it's SQLEXPRESS, check it is on port 1433. It doesn't default to a fixed port.
One other thing, I'm not sure that the name 'localhost' is understood. Try

Other than that, time outs are normally caused by firewall or SQL not listening on the interface.

yes, i just fixed it and those two were exactly the problem, i was pointing to the wrong port and instance name.
Anyways, thanks for the help!

Pleasure to help. I don't think there are many SQL Server errors that I've not seen!