Cant add series to graphs in dashboard

I can access the Add Series widget.
image

But when I access it I can’t add any queries to the graph because I get the following error.

Cannot read property ‘type’ of null

In the “Search for a question” searcher.

I have tried to replicate the same graphs in new dashboards and the issue still stands. That’s why I know it’s not a problem with the type of data in the X-axis or the Y-axis. That’s why I can only identify it as a bug.

Thanks,

Hi @Vallistruqui, can you please send the version you are in and the steps to reproduce this (specially with the sample dataset, otherwise we won’t be able to reproduce it locally)? Were both questions built using plain SQL or you used the GUI? Remember that in order to overlap questions you need to have questions that use the same x-axis values at least

Hi @Vallistruqui
Sounds like the same problem as this closed issue, which seems to be caused by a corrupted question, but I haven’t figured out how to reproduce the problem.
https://github.com/metabase/metabase/issues/13465

Hi @flamber, I have looked through the github solution you provided. I too think It’s a very similar issue. But I couldn’t understand the process in which the corrupted question was identified. If you could help me through that issue, I’d be greatful.

Thanks,

@Vallistruqui Have a look at this topic, which was from the other day: Charts comparision is not working after upgrade (0.37.5)
If you are still having problems, then write. I’ve tried several different things to create a bad/corrupted question, but I cannot reproduce this. Would love to figure out how to reproduce, since it’s a million times easier to fix issues then.

Thanks a lot flamber, I was able to delete 3 corrupted queries and the dashboards were functional once again. Great support.