Can't login through squid proxy

Hello, whenever I try to login using a proxy (Squid) that is not sending the IP address in the HTTP request I get the following:

ERROR metabase.api.session Error de autenticación
clojure.lang.ExceptionInfo: Output of device-info does not match schema:
{:ip_address (not ("Non-blank string" ""))}

Is there any way to disable this check?

Thanks in advance!

  "browser-info": {
    "language": "en-US",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.13+8",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "11.0.13",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.13+8",
    "": "Linux",
    "os.version": "5.4.0-91-generic",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "mysql",
    "application-database-details": {
      "database": {
        "name": "MySQL",
        "version": "8.0.27"
      "jdbc-driver": {
        "name": "MariaDB Connector/J",
        "version": "2.6.2"
    "run-mode": "prod",
    "version": {
      "date": "2021-12-02",
      "tag": "v0.41.3.1",
      "branch": "release-x.41.x",
      "hash": "20f9097"
    "settings": {
      "report-timezone": null

Hi @rgarciap
Then make it send an IP address. If you don't send an IP, then there's several security features that won't work in Metabase.
You would have to build your own version of Metabase if you need those removed.