Card stuck on top of another and can't make any changes

Urgent - cannot make any more changes to this dashboard
I cannot delete cards or add cards and the dashboard freezes
Screenshot attached.

I tried adding a new question and it got overlayed on top of another and now I can’t drag it or move anything around with my mouse getting stuck.

I tried revision history and get “revert failed”

Hi @rishub
Please post “Diagnostic Info” from Admin > Troubleshooting.

@flamber
{
“browser-info”: {
“language”: “en-US”,
“platform”: “MacIntel”,
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.96 Safari/537.36”,
“vendor”: “Google Inc.”
},
“system-info”: {
“file.encoding”: “UTF-8”,
“java.runtime.name”: “OpenJDK Runtime Environment”,
“java.runtime.version”: “11.0.7+10”,
“java.vendor”: “AdoptOpenJDK”,
“java.vendor.url”: “https://adoptopenjdk.net/”,
“java.version”: “11.0.7”,
“java.vm.name”: “OpenJDK 64-Bit Server VM”,
“java.vm.version”: “11.0.7+10”,
“os.name”: “Linux”,
“os.version”: “4.14.181-140.257.amzn2.x86_64”,
“user.language”: “en”,
“user.timezone”: “GMT”
},
“metabase-info”: {
“databases”: [
“googleanalytics”,
“mysql”,
“h2”
],
“hosting-env”: “elastic-beanstalk”,
“application-database”: “postgres”,
“application-database-details”: {
“database”: {
“name”: “PostgreSQL”,
“version”: “11.8”
},
“jdbc-driver”: {
“name”: “PostgreSQL JDBC Driver”,
“version”: “42.2.8”
}
},
“run-mode”: “prod”,
“version”: {
“date”: “2020-07-21”,
“tag”: “v0.36.0”,
“branch”: “release-0.36.x”,
“hash”: “b31049f”
},
“settings”: {
“report-timezone”: null
}
}
}

@rishub Upgrade to a newer release. Latest release is 0.37.8

But I’m not sure if that will fix the corruption that already exist in the dashboard, so you might need to remove the card(s) with the following command in your browser console. You can find the cards on the dashboard in the application database table report_dashboardcard.

Replace host and :id s with appropriate dashboard/card ID:

await fetch("https://metabase.example.com/api/dashboard/:id/cards?dashcardId=:id", {
    "credentials": "include",
    "headers": { "Content-Type": "application/json" },
    "method": "DELETE",
    "mode": "cors"
});

@flamber how do i get the card id?

@rishub You can find card IDs for the problematic dashboard in report_dashboardcard - that’s a table in your application database.

@flamber sorry which application database? how can i connect to this?

@rishub
Metabase’s application database. You are using Postgres: "application-database": "postgres"