Change Metabase instance protocol from HTTP to HTTPS

My Metabase (residing on an AWS EC2 instance) is currently accessible via:

However, I want to use HTTPS instead for more security, such that my Metabase is accessible via:

How can I achieve this? I tried changing the Site URL in Admin Settings -> General -> Site URL, but of course that did not work.

Hi @daniel11
You would need something that handles the HTTPS traffic - load-balancer, reverse-proxy, etc.
Try searching the forum or internet for reverse-proxy (ex. Nginx) and SSL.