Columns not appearing in filter/summarize/sort

Hi,

I have saved an SQL query as a question. This query returns eight columns (fields). I have then created a Simple Question using the saved question as a source. When I view or preview the data I see all eight columns. But when I select the Columns, Filter, Summarize or Sort options, only six of the columns are available. I have forced a sync and re-scan (via Admin->Databases) although I don’t think this is the problem.

The attached image demonstrates what I mean.

FWIW, the two columns that are not appearing are both numeric (INTEGER and DOUBLE) whereas all other columns are not. I have tried CASTing the integer column to varchar but it made no difference.

We are on v0.35.2 on Ubuntu connecting to PostgreSQL.

Thanks in advance.

Jeffery

Hi @jcandiloro
Latest release is 0.35.4

One thing that I’m noticing is that the “Select All” is partially checked, which means that some columns are not included.
Where the two missing columns added after you initially created the SQL question?
If you refresh the browser, do the columns then appear?

Have a feeling that you might be seeing this issue:
https://github.com/metabase/metabase/issues/7612 - upvote by clicking :+1: on the first post

Hi @flamber,

Sorry for the delay in replying.

It wasn’t an issue with the Select All (I had tried playing with that a few times to see if it was the cause).

It turned out to be something caching somewhere (a very precise explanation, I know). When I created a new question and pasted in the exact same SQL, all the columns appeared as expected. At that point I moved onto the work I actually needed to complete rather than try to solve the problem any further.

Thanks for your help.

Jeffery