Connection Refused while connecting to upstream

Hi - has anyone else experienced this error with Elastic Beanstalk? I am hosting the application in Ireland in a VPC and am not sure why this error is occurring.

@camsaul @sameer

@alexandralouise I haven’t seen that error before :sweat:

This seems like it could be a random issue that might be fixed by restarting the instance, give that a go and let me know if it works?

Disabling default_server in nginx fixed it for me. (which may not be the best solution)

Platform: 64bit Amazon Linux 2017.03 v2.6.0 running Docker 1.12.6
Metabase version: v0.25.2

sudo rm /etc/nginx/sites-enabled/default_server
sudo /etc/init.d/nginx reload
1 Like

I believe it’s related to NGINX_SERVER_NAME being broken, see

Try unsetting the NGINX_SERVER_NAME env variable in your aws settings should fix this.

This should be fixed by