Couldn't connect to database

Error message reading “Couldn’t connect to the database. Please check the connection details.” when attempting to connect to Redshift database.
The following IP addresses are whitelisted by Redshift:

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 11_2_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.192 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.7+9-202002041938",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "",
    "java.version": "11.0.7",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.7+9-202002041938",
    "": "Mac OS X",
    "os.version": "10.16",
    "user.language": "en",
    "user.timezone": "America/New_York"
  "metabase-info": {
    "databases": [
    "hosting-env": "osx",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
    "run-mode": "prod",
    "version": {
      "date": "2021-02-19",
      "tag": "v0.38.0.1",
      "branch": "release-x.38.x",
      "hash": "0635914"
    "settings": {
      "report-timezone": null

To help diagnose: we were able to connect when we turned off the firewall

Hi @kdonnelly
Why are you adding the Metabase Cloud to your allow-list?
You are running Metabase self-hosted on your local computer, so you need to add your IP to the allow-list.
I would recommend using the JAR or Docker instead of the Mac App.

hey thanks so much for getting back to me!

I added my computer’s IP address to the allow-list and used JAR to run Metabase, and I was still unable to connect.

@kdonnelly Then it’s probably the wrong IP you’re using, or perhaps you have dynamic changing IP.
Check what your IP is here:
The problem is not Metabase, since everything works, when you disabled the firewall - that should tell you that it’s a networking problem.

my bad i added my private ip address instead of my public! thank you!