Custom fields not working for me

Hi all,

I am trying to create a simple custom field = field1 - field2
Also, custom expressions are not allowing me to choose/type fields either
It doesnt seem to want to accept my field selection and the done button remains disabled?

Can you provide more details about your browser, OS, database, and Metabase version please? Thanks!

Hi Maz,

I am still running v0.22.2, that’s 2 versions ago. I had a look at the release notes and couldn’t find anything logged for this issue. I will try upgrading shortly and then retry. We are running Metabase on a EC2 instance on AWS with Linux Jessie I believe. I am using latest chrome version.
Thank you for the response.

Cool. Without more details, one thing I could guess at is that field1 and field2 possibly aren’t marked as Numbers in the metadata section of the AdminPanel.

thx maz, I will go check it out, they should be 2 decimal fields but I will go check that.

Hi Maz,

I updated the metadata to be numbers for those 2 columns, but still doesnt behave very well. I even tried a fresh install of metabase locally in docker and it does the same thing. Does this functionality work for you?

Oh, I think this might just be a dumb UX issue: does the button light up if you give your formula a name? (I just tested this and it is working for me.)

Hi Maz, it doesnt allow me to type anything, only allows selection from the list of fields thats all, everything else is ignored, maybe i try a different browser…

UPDATE! works fine in firefox, but chrome simply refuses anything in the name field

Super weird, but it might be something we’ve fixed since v.22

awesome yeah, i need to upgrade! Thanks for the feedback, really appreciate it.

I’m using v0.23.1 there’s a similar issue with custom expression in the questions.

Can’t enter anything (gets stuck on the functions selection). Doesn’t work in Chrome or firefox. Does work in Safari.

yes, I actually tried it in a new docker install using the :latest tag, same thing.
I got it working in Firefox though. I found the same issue when trying to specify a custom expression in the VIEW section.

The issue where the cursor gets stuck in v0.23.1 was fixed in 0.24.

Nice, thank you! :clap:

1 Like