Custom Maps don't work

(My Metabase verson is 0.39.3.)
Hi, I tried to upload my custom map, but ended up getting this error. Can someone help me out what I can to to resolve this issue?

https://raw.githubusercontent.com/weiting-1993/Germany-Maps-GeoJSON-files/main/Deutschland_Bundesland.json

Hi @wtlin
Unless the server where Metabase is hosted cannot connect to the map source host, then it's likely because you didn't provide a name before inputting the URL:

If that works, then you're seeing this issue:
https://github.com/metabase/metabase/issues/14635 - upvote by clicking :+1: on the first post

Hello @flamber

Thank you for your reply!

I saw that post earlier while trying to solve the problem and tried the workaround you provided. I tried multiple times, but it somehow just didn't work. I just tried to add a map like 5 minutes ago after reading your reply and this time it worked without even using the trick you provided.

By the way, I already clicking :+1: long time ago when I first asked a question here and also got a reply from you.

@wtlin Are you running multiple instance? Or could it be network problems (DNS etc) on your instance?
That's the only reason why it would fail, but without further details, then we will fix the issue, but that might not fix your problems if it is caused by something else.
Try opening an incognito window and see if you can reproduce the problem and make note of everything you do.
And post "Diagnostic Info" from Admin > Troubleshooting.

@flamber
We only run one instance.

(Problem_1) I tested on incognito window. Instead of showing the invalid custom GeoJSON key, after I clicked on the map that was already created, the edit popup would show up first, then you saw the loading sign, and then the popup just closed by itself. On the right bottom of the window I got this small information window.

(Problem_2) Beside that, there are another odd thing. I tried to add other new maps, if I first put in the URL (I did give it a name before entering URL) which the file is stored at the git provider that is hosted on our own private server, I then got the same problem as clicked on the existed map and got the same error message as the attached pictures. If I first put in the URL which the file is stored at a public git provider, load the file and wait until it finished loading, then replace the URL with the one that is hosted on our own server and it works.

However, after a while (like 10-15 minutes) I clicked on the map that I just created and then I got the problem_1 again and those maps I just successfully created were uneditable and unusable again.


15

@wtlin Would it be possible for you to just copy-and-paste the content of "Something went wrong".
It is not possible to search pictures, so if someone has the same error as you, then they would never find this topic.

I'm not sure if the problem relates to you using MySQL 5.6 as the application database, but the minimum required version for Metabase is 5.7.7:
https://www.metabase.com/docs/latest/operations-guide/configuring-application-database.html#mysql-or-mariadb

I have a feeling that you are using some proxy that is causing some of these problems.
It would require you to post the maps you're using (the actual addresses), so others can reproduce - otherwise I don't see how we will ever be able to fix something blindly, when we don't know what the problem is.

Here is the url for the map. https://raw.githubusercontent.com/weiting-1993/Germany-Maps-GeoJSON-files/main/Deutschland_Ort.json

I don't really think it's the problem of the file itself because with the same file, it sometimes works and sometimes doesn't work. For example, I just tried to add maps again and the first time I successfully add a new map and when I tried to add another one. I got the error message as showing below.

I will ask my colleagues about the setting of our proxy.

Below is the error message:

Something went wrong

in GeoJsonPropertySelect
in div
in SettingContainer
in div
in div
in div
in div
in EditMap
in div
in div
in OnClickOutsideWrapper
in div
in CSSTransitionGroupChild
in span
in TransitionGroup
in CSSTransitionGroup
in div
in Unknown
in WindowModal
in k
in div
in CustomGeoJSONWidget
in div
in li
in SettingsSetting
in ul
in div
in div
in div
in AdminLayout
in t
in Title[t]
in SettingsEditorApp
in Unknown
in Title[]
in Unknown
in UserIsAdmin(Component)
in Connect(UserIsAdmin(Component))
in UserIsAuthenticated(Connect(UserIsAdmin(Component)))
in Connect(UserIsAuthenticated(Connect(UserIsAdmin(Component))))
in MetabaseIsSetup(Connect(UserIsAuthenticated(Connect(UserIsAdmin(Component)))))
in Connect(MetabaseIsSetup(Connect(UserIsAuthenticated(Connect(UserIsAdmin(Component))))))
in BackgroundApplicator
in Title[BackgroundApplicator]
in div
in t
in ScrollToTop
in t
in App
in Title[App]
in RouterContext
in Router
in t
in DragDropContextProvider
in a
1 Like

@wtlin I would recommend that you try running Metabase locally on your computer. If you can reproduce any of the problems, then there's something to investigate, but I'm 95% sure it's something to do with your current setup/hosting.
I have spend way too many hours tracking down the strangest errors and this problem looks like a proxy issue or multi-instance issue, and you say you're only running one instance, so:
https://www.metabase.com/docs/latest/troubleshooting-guide/proxies.html

1 Like