Custom region map import

When I use custom region map in admin panel, the region name is not displayed correctly!
My geojson file use UTF-8.

Is the problem only in the admin panel - or is it also a problem when using the map?

Can you share your geojson file so it’s easier for others to evaluate the problem?

There both have the problem!

I think I face similar issue, cities are displayed while using, but not matched with results
JSONident
It came from here
Sometimes during import into mapshaper.org (but not with this file), I have to set import options: “encoding=1250”
Maybe some similar setting needed here?

Hi @CZvacko
Maps has to be UTF-8 encoded, and you need to define -Dfile.encoding=UTF-8 when starting Metabase, if your Java uses a different encoding - see Admin > Troubleshooting > Diagnostic Info what Metabase reads from Java.

How to define it under windows OS ? When I launch Metabase by java -jar metabase.jar -Dfile.encoding=UTF-8
then I get
Unrecognized command: -Dfile.encoding=UTF-8
Valid commands are:....

And if maps have to be always UTF-8 encoded, why Metabase cannot launch like this by default ?

@CZvacko java -Dfile.encoding=UTF-8 -jar metabase.jar
There’s an issue open now:
https://github.com/metabase/metabase/issues/12962 - upvote by clicking :+1: on the first post

Ok, wrong sequence of parameters, now its ok.
BTW, in 0.35 was possible “inject” geojson file into JAR, then there was no issue with encoding or using other web server. This was avoided?

@CZvacko I don’t understand what you’re saying.

@flamber
It was possible modify geojson.clj file (add some lines) and add related json file into metabase.jar. Same procedure doesn’t work in 0.36. It saved me a lot of trouble loading json file from other webserver :innocent:

@CZvacko You shouldn’t need to modify anything in geojson.clj
Just add the files to the same location as the two included maps, and then you just reference that in Admin > Settings > Map: (where http://localhost:3001 is the Metabase Site URL)
http://localhost:3001/app/assets/geojson/world.json

@flamber
Nice trick :smiley:, this works better.