Dashboard Fitlers: cannot select corresponding question field


I have a dashboard with filters, but my the field I need to filter my question on is not appearing in the list of options here:

I tried to remove fields from the question hoping that the correct field would then show up, but this seems to have no effect. Am I missing something here? Thanks for the help!

Hi @hawisizu
Post "Diagnostic Info" from Admin > Troubleshooting.
Which type of question is it? SQL or GUI, and if GUI is it based on another question?
Have you set the Field Type in Admin > Data Model?

Diagnostic info pasted below.
The question is a simple question based on a table, in this simply listing the rows of a table (not all the columns).

The field type was not set, and indeed setting it up solved the problem. Sorry if that was indicated in the doc, I tried to search but didn't find it... Thanks!

  "browser-info": {
    "language": "en-GB",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.11",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9",
    "os.name": "Linux",
    "os.version": "4.9.0-11-amd64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.7"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.18"
    "run-mode": "prod",
    "version": {
      "date": "2021-04-27",
      "tag": "v0.39.1",
      "branch": "release-x.39.x",
      "hash": "6beba48"
    "settings": {
      "report-timezone": null