Data Model Prohibitively Slow

We have a very large instance of Metabase and one Postgre database's data model page in Metabase is prohibitively slow to the point of not being usable.

Any tips? I have tried turning off automatic syncing - ie enabled the following. This is a large database, so let me choose when Metabase syncs and scans.

Here is a look at how slow it is: https://share.redwhale.co/YEuRezwm

We have quite the volume of commuting resources for this instance.
Any tips appreciated! Thanks.

Hi @Brandonlipman
Post "Diagnostic Info" from Admin > Troubleshooting. Have you tried with different browsers, or without any extensions?
How many schemas/tables/columns do you have? And how many columns are there on the specific page you're showing in the video?
You cannot disable sync - only scan can be disabled, but it's unrelated to your problem.

Hey @flamber - :slight_smile: The data is coming from Stitch a data warehouse (only a select amount of tables are causing it) ones with lots of columns. All other schemas and tables are performing fine in Metabase.

We dropped several this morning at the time of the recording we were at 1200 columns. Now we are at 376 columns. Still same lag problem.

{
  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.85 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.11+9",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.11",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.11+9",
    "os.name": "Linux",
    "os.version": "4.15.0-91-generic",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "postgres",
      "mysql",
      "googleanalytics"
    ],
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "12.4"
      },
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.18"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2021-04-27",
      "tag": "v0.39.1",
      "branch": "release-x.39.x",
      "hash": "6beba48"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

@Brandonlipman Okay, so you had 1200 columns in a single table. I think I can say that not many programs are optimized for that scenario.
I have 180 columns in some tables, but not seeing any noticeable slowdown in Data Model, when the columns have been loaded.