Date filter Chinese character improper in ver.0.43

Thanks a lot to the dev team for bringing the new version 0.43, which includes tons of new features and enhancements. And I wish to report a small flaw, in hopes it may help to make the platform more perfect, especially for users in Chinese environment.

It is about the new date filter, in which I found the Chinese characters indicating the weekdays are not proper. If correctly shown, they would have been ”日 一 二 三 四 五 六”, which means Sunday and one,two,three,four,five and six of the weekdays.

Would you kindly please check the issue above and the picture attached.

Thanks again for your great job and kindness.

Andrew Wang from PRC

Hi @Chivalry
It sounds like you are seeing this issue, which we have fixed in the upcoming 0.43.1:
https://github.com/metabase/metabase/issues/22171

Thanks a lot and I am looking forward to the coming version.

Hi @flamber, I upgraded to version 0.431, and found that the issue were still there. Would you please kindly check it again? We have a lot of users here viewing tables and charts everyday, and the correct characters are highly appreciated.

Thanks a million.

@Chivalry Post "Diagnostic Info" from Admin > Troubleshooting.

@flamberThanks

{
"browser-info": {
"language": "zh-CN",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.41 Safari/537.36",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "GBK",
"java.runtime.name": "Java(TM) SE Runtime Environment",
"java.runtime.version": "14.0.1+7",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "https://java.oracle.com/",
"java.version": "14.0.1",
"java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
"java.vm.version": "14.0.1+7",
"os.name": "Windows Server 2016",
"os.version": "10.0",
"user.language": "zh",
"user.timezone": "Asia/Shanghai"
},
"metabase-info": {
"databases": [
"h2",
"mysql"
],
"hosting-env": "unknown",
"application-database": "mysql",
"application-database-details": {
"database": {
"name": "MySQL",
"version": "8.0.29"
},
"jdbc-driver": {
"name": "MariaDB Connector/J",
"version": "2.7.5"
}
},
"run-mode": "prod",
"version": {
"date": "2022-05-16",
"tag": "v0.43.1",
"branch": "release-x.43.x",
"hash": "7f1a1c4"
},
"settings": {
"report-timezone": "Asia/Shanghai"
}
}
}

@Chivalry Upgrade to Java 11 or 17. Java 14 has been end-of-life for several years.
https://www.metabase.com/docs/latest/operations-guide/java-versions.html

I still do not understand what the problem is with the calendar. I don't understand Chinese, so unless you provide a lot more details about what the problem is, then it will not be fixed.
Metabase uses MomentJS, so perhaps the bug is somewhere in that library: https://github.com/moment/moment/

Hi @flamber, Thanks for your patience, and I am showing you the difference from a earlier version.

This is a picture from ver0.420, in which the Chinese characters were correctly shown, as ”日, 一, 二, 三, 四, 五, 六”, which means Sunday and one,two,three,four,five and six of the weekdays.

And in ver 0.431, the picture is shown as below:

And I checked the link you referred earlier (https://github.com/metabase/metabase/issues/22171), in which a gentleman reported a bug regarding the language collation setting of “zh” and “zh-cn”, maybe there is still something to to with that?