Drop Down List Box Filters Embedded Not Working

I have a dashboard in Metabase v0.37.5. It has been working fine with drop down list box filters working correctly while embedded. Now the dropdown list box works in Metabase, when I click the embedded icon and go to embedded settings, one filter is listed as locked. When I test by adding a value to the locked filter (with known results in the dataset) none of the filters work. If I change the locked filter to editable, it still does not have values int he drop down list boxes. When I test, while embedded, the filters are Plain Input and not list boxes. Is this a bug, an upgrade issue or am I just nuts?


I have been playing around with this a bit more and it doesn’t look like the filters display drop down list box (even when specified in the Data Model) on the embedded page. I even upgraded our development environment and created a dashboard from scratch with a new question (trying to eliminate errors based on upgrades) and seems like maybe this functionality is broken for displaying a list box while embedded.

Hi @Slickrock22
How are you embedding? Have a look in this issue: https://github.com/metabase/metabase/issues/14474
Also have a look in https://github.com/metabase/metabase/issues/13832 and the referenced issues.

@flamber thanks for the response. The first issue URL looked exactly like what I was experiencing. After further investigation it looks like Filter Drop Down lists do not work by design while on the embedded configuration page even when you add a test value into the locked parameter and that value has associated filters. Our issue was we were not passing the correct value into the locked parameter while embedded. Some questions showed values because they were not connected to the filter on the dashboard and thus did not need a parameter to be display.

Can I ask? How is the implementation in Codeigniter?

@Zeddd I don't know Codeigniter. Trying searching in one of their forums how to code.
Or have a look here: [SOLVED] Error when embedding dashboard