Error on zoom

#1

I have a pivot table that counts the number of rows for each row - column combination:

|ID | 2010 | 2011 | 2012|
|A | 10 | 2 | 50 |
|B | 3 | 55 | 20 |
|C | 2 | 4 | 5 |

Clicking the numbers “to view records” works fine, but the zoom gives the following error:

Output of fks->join-information does not match schema: e[0;33m [nil {:pk-field-id (not (integer? nil))}] e[0m

  1. Any idea on what the error is referring to?
  2. Should Zoom even be an option on tabluar data ?
  3. How does “zoom” differ from “View records” when working with tabular data?

thanks much

#2

Hi @brianwilson
Which version of Metabase?
First look, it seems like maybe the Field Type’s are not adjusted correctly? Admin Settings > Data Model > (database) > (table) > (column) :gear:

#3

Dear @flamber, I am using v0.32.4 (linux Server OS, chromium V51 browser). Not sure about the data type as I’m simply using “count of rows” which gets flipped in a pivot table. I am grouping by a field from a FK’d dimension. If I group by a field in th eprimary “fact” table the zoom seems to work. Check the data type on both tables for the field (its the entity key in the dimension table) in question seems okay.

#4

@brianwilson
Okay, I would recommend that you upgrade to 0.32.8 - there are some other known issues with the version you’re using.
I’ve been trying to reproduce your issue, but I cannot get it create the error you’re seeing, so I would think it’s somehow related to Field Type or the actual database column type.
Someone created an issue a couple of months ago, but I haven’t been able to reproduce that either:
https://github.com/metabase/metabase/issues/9516