Error setting up Oracle database 19c


While I was setting my new instance of Metabase, I faced the following error: IO Error: Invalid number format for port number

However, the number is correct and there is no blank space in the beginning nor in the ending of the field.

What should I do to make it work?

My database installation is the Oracle Database 19c Enterprise Edition Release - Production

Other settings include:
--- Java installation ---
openjdk 11.0.11 2021-04-20
OpenJDK Runtime Environment (build 11.0.11+9-post-Debian-1deb10u1)
OpenJDK 64-Bit Server VM (build 11.0.11+9-post-Debian-1deb10u1, mixed mode, sharing)

--- Linux version ---
Distributor ID: Debian
Description: Debian GNU/Linux 10 (buster)
Release: 10
Codename: buster

Thank you in advance,

Hi @Freeny
Post "Diagnostic Info" from Admin > Troubleshooting.
And which version of the ojdbc8.jar driver are you using?
And could it be that you're specifying Service Name, but not SID?

"browser-info": {
"language": "pt-BR",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0",
"vendor": ""
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9-post-Debian-1deb10u1",
"java.vendor": "Debian",
"java.vendor.url": "",
"java.version": "11.0.11",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.11+9-post-Debian-1deb10u1",
"": "Linux",
"os.version": "5.6.4-minmvs",
"user.language": "pt",
"user.timezone": "America/Sao_Paulo"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "h2",
"application-database-details": {
"database": {
"name": "H2",
"version": "1.4.197 (2018-03-18)"
"jdbc-driver": {
"name": "H2 JDBC Driver",
"version": "1.4.197 (2018-03-18)"
"run-mode": "prod",
"version": {
"date": "2021-04-27",
"tag": "v0.39.1",
"branch": "release-x.39.x",
"hash": "6beba48"
"settings": {
"report-timezone": null

JDBC Version
To download the JDBC I ran: wget

I specified all fields in the form, so I guess it is not the problem

@Freeny Okay, so you're using ojdbc8.jar version 19.10.
Try with, since I guess it has something to do with the fields you fill out.
Do you even need to fill out SID or Service Name to connect to your database?

I tried to not fill the SID field and it worked! Thank you!