ERROR: '' You do not have permissions to run native ad-hoc queries against database 3. ''

Thanks @flamber!
I tried to provide you all the screen shots but I am only allowed one image?
7) Error:
image

@wtomlinson Try again, otherwise post one image in each comment.

Here are the steps:

  1. Click ask question
    image
  2. Click simple question
    image
  3. Click database and table
    image
  4. Click to Save
    image
  5. Click Save
    image
  6. Error
    image

Permissions:
image
image

@wtomlinson I’ve tried several times to reproduce this, but without success. There must be some setting or a step that isn’t included.
I’m unsure if it is specific to the database type of the source, or data permission thing I’m not seeing. Or perhaps something completely different, that I’m not seeing.

How can I help further? I am happy to do a screen share and show you the needed aspects of our setup. Thanks

@wtomlinson I’m essentially trying to see if I can reproduce this on a new setup only with Sample Dataset, since it makes it a lot easier for me to write up the steps and then we can easily create tests for this, once it’s fixed, so this problem never occurs again.

Which database type is “Bolt” ?
Does “Inside sales” group only have access to specific tables or the entire Bolt database ?
Does the group have access to other databases?

I know there has been several fixes to other permission problems in 0.36, so it might be worth trying that. Remember to backup before upgrading, since you have to revert to the backup if you want to downgrade. Latest release is 0.36.2

Thanks @flamber. I will work to update to the latest release.
Bolt is a SQL Server
Inside Sales group has access to specific tables. In my example, they DO have access to the table the question was looking at. They do NOT have access to run ad-hoc queries. I have tested turning that on but it doesn’t make a difference for this error.
Inside Sales has limited access to one other SQL Server database.

@wtomlinson Now I’ve just tested with SQL Server on 0.35.4 as well, but I cannot get it to fail.
If it works on 0.36.2, then great, otherwise it would be extremely helpful if you could setup a test instance, where you only add the minimum groups, users, databases, etc to reproduce this problem.