Filter by date is showing results from the previous day as well

If I filter on a date it always shows me the date before as well. I’m not sure why. Please see screenshots attached.

Only when I run the query through the query editor does it actually work.

So the actual number of records should be 11 (as in the last image/SQLeditor) but the main view shows 23.

(so it’s not letting me paste in the second image as I’m a new user, but I’d be happy to put that in a subsequent comment or response.

Here’s the second image I referenced.

Hi @godzilla
Please post the Diagnostic Info from Admin > Troubleshooting.
My guess is that you’re seeing exactly the same problem as discussed here from post 21: Aggregations on Individual "Grouped By" Fields AND Showing the records within each group
It’s fixed on master (the upcoming 0.34.0)

Hi @flamber, thanks for the prompt response! I’ll look into that issue/bug.

Here’s my diagnostic info:

{
  "browser-info": {
    "language": "en-US",
    "platform": "Linux x86_64",
    "userAgent": "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.4+11",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.4",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.4+11",
    "os.name": "Linux",
    "os.version": "4.14.146-93.123.amzn1.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "postgres"
    ],
    "hosting-env": "elastic-beanstalk",
    "application-database": "postgres",
    "run-mode": "prod",
    "version": {
      "date": "2019-11-07",
      "tag": "v0.33.5",
      "branch": "release-0.33.x",
      "hash": "bf436b4"
    },
    "settings": {
      "report-timezone": "US/Eastern"
    }
  }
}

@godzilla Upgrade to 0.33.5.1 or latest 0.33.6. There was a build problem on 0.33.5

Splendid! That was it; it works now. I’m surprised that a build issue caused a bizarre bug like this. Thank you!

1 Like

I’m happy to close this bug report now. @flamber

@godzilla
I have a feeling that PR #11111 fixed your problem, since the upgrade to 0.33.5.1+ resolved it.
Forum topics are not “closed”, that’s only the issue tracker on Github that works like that, so a response that everything is working is perfect :+1: