Filter for custom SQL query

Hi Metabase team,
Since new version of Metabase 0.40, for public dashboard with filters, with a native SQL query, the filters don't work anymore.

"browser-info": {
"language": "en-US",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.124 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "Cp1252",
"": "Java(TM) SE Runtime Environment",
"java.runtime.version": "1.8.0_221-b11",
"java.vendor": "Oracle Corporation",
"java.vendor.url": "",
"java.version": "1.8.0_221",
"": "Java HotSpot(TM) 64-Bit Server VM",
"java.vm.version": "25.221-b11",
"": "Windows Server 2016",
"os.version": "10.0",
"user.language": "en",
"user.timezone": "Europe/Paris"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "12.2"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
"run-mode": "prod",
"version": {
"tag": "v0.40.0",
"date": "2021-07-08",
"branch": "master",
"hash": "961caed"
"settings": {
"report-timezone": "Europe/Paris"

Best regards

Hi @nico8
What does "don't work anymore" mean? Can you provide steps to reproduce?

Very simple : I have created a question (Native Query) connected to a MS SQL Server source.
In my question, I have 3 variables to have 3 filters for the query : 1 for the shop number and the date (begin and end).
I have published my question with a public sharing.
When I access to my question in public sharing, I try to add a value for one of the filter, but nothing happen.
If I fill the shop number and press enter, nothing happen, the URL is refreshed but the filter has no effect and the field is blank. If I select a Date, the URL is refreshed by the question is not filtered.
I downgrad to version 0.39 and it works.


@nico8 Great, so it's only a problem with the question, not via dashboards, which you wrote initially: - upvote by clicking :+1: on the first post