"Filtering on this field" as "A list of all values" doesn't work

Hi guys,

I am trying to get a list of all values in a field called "Denomination", but it is not working. Instead, this option is working correctly on other fields in the same table in the same database. I have tried re-scanning this field, discarding the cached field values and it still doesn't work.... Any suggestions? My databases are hosted on Snowflake. The field configuration and field type are the same, in some of them this option works and in others it doesn't and I don't understand why. I attach some screenshots.

Category_filter_options

Best regards.

Hi @miquelmartorell
Post "Diagnostic Info" from Admin > Troubleshooting.
What is the Field Type and filtering type in Admin > Data Model > (db) > (table) > (column) :gear:?
How many distinct values does the field have?

Hi @flamber

This is my Diagnostic Info:

{
"browser-info": {
"language": "es",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36 Edg/90.0.818.56",
"vendor": "Google Inc."
},
"system-info": {
"file.encoding": "UTF-8",
"java.runtime.name": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.11+9",
"java.vendor": "AdoptOpenJDK",
"java.vendor.url": "https://adoptopenjdk.net/",
"java.version": "11.0.11",
"java.vm.name": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.11+9",
"os.name": "Linux",
"os.version": "5.4.0-72-generic",
"user.language": "en",
"user.timezone": "CET"
},
"metabase-info": {
"databases": [
"h2",
"snowflake"
],
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "12.6 (Ubuntu 12.6-1.pgdg20.04+1)"
},
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.18"
}
},
"run-mode": "prod",
"version": {
"date": "2021-04-27",
"tag": "v0.39.1",
"branch": "release-x.39.x",
"hash": "6beba48"
},
"settings": {
"report-timezone": null
}
}
}

The field type is "Category" (type/Text if is original schema)

I have approximately 11,000 unique records in this field.

Thank you very much.

Best regards.

@miquelmartorell Metabase will not show a dropdown, when the field has more than 300 distinct values. You should use the Searchbox instead.
https://github.com/metabase/metabase/issues/7603 - upvote by clicking :+1: on the first post

Upvote done in the Github link.

Thank you very much for the info @flamber