Filters still not showing after type adjustment

I’m trying to have Metabase see all columns on a table as potential dashboard-level filters. However it only picked up the type for 2 or 3 columns automatically.

I adjusted the types of the other columns in the data model:

But it still doesn’t allow these new types (price etc.) to be chosen as filters. They don’t show up in the dropdown:

The only options it shows are the original ones that Metabase picked up automatically during introspection.

I’ve tried clearing the cache and re-scanning the table via the data model after doing this and re-adding it as a question and to the dashboard, also.

Perhaps there’s something I’m missing?

This seems like the related GitHub issue:

If you think so as well maybe you can provide the input @salsakran was asking for in his comment in that issue. That might help figuring out if there’s a bug and what’s happening…

Interesting, these aren’t FK but it could be related.
Thanks Jorn, will try on a different platform/db connection to see if the issue persists.

UPDATE: Thankfully its working fine on my Ubuntu install, the original error appeared for me on OS X.
Will stick with this for the time being.