Frequent GC makes metabase webui unavailable

If we query a table of tidb without limiting the number of rows, and the table has tens of millions of rows, metabase will frequently full GC, at this time, the whole web will not refresh anything

However, if the table in hive is queried, this will not happen

“browser-info”: {
“language”: “zh-CN”,
“platform”: “Win32”,
“userAgent”: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.61 Safari/537.36”,
“vendor”: “Google Inc.”
“system-info”: {
“”: “Java™ SE Runtime Environment”,
“java.runtime.version”: “1.8.0_45-b14”,
“java.vendor”: “Oracle Corporation”,
“java.vendor.url”: “”,
“java.version”: “1.8.0_45”,
“”: “Java HotSpot™ 64-Bit Server VM”,
“java.vm.version”: “25.45-b02”,
“”: “Linux”,
“os.version”: “3.10.0-957.el7.x86_64”,
“user.language”: “en”,
“user.timezone”: “Asia/Shanghai”
“metabase-info”: {
“databases”: [
“hosting-env”: “unknown”,
“application-database”: “mysql”,
“run-mode”: “prod”,
“version”: {
“tag”: “v0.33.7.3”,
“date”: “2019-12-16”,
“branch”: “release-0.33.x”,
“hash”: “7ee7193”
“settings”: {
“report-timezone”: “Asia/Hong_Kong”

Hi @rayn
The latest release is 0.35.4

Metabase does not technically support TiDB unless what you’re experiencing is also a MySQL bug.
There are a lot of databases that promise MySQL or PostgreSQL compatibility that don’t actually deliver it.

Thank you for your reply. I’ll try to update the version

@rayn And you should update Java too: