Friendly Column names not shown anymore

Hi there,

I’m currently running Metabase v0.33.1 and have noticed that the column names declared as aliases in SQL (i.e. “my_column”) are not following the FRIENDLY TABLE AND FIELD NAMES setting to replace underscores with spaces.

I tried finding any issues or traces of this change in Github as well, so I’m not sure if this is a bug or intended behaviour.

49

Regards.
G

@gvv
I don’t remember seeing any code related to humanization of column names in 0.33.1.
Did this used to work with 0.33.0? If yes, then you should open an issue.

Hi @flamber,

I have noticed this issue since 0.32.10 to be honest and was waiting for 0.33.1 before creating an issue. I will open one now.

Thank you!

@gvv
Okay, that changes a lot. There has been so many changes - also to humanization.
I can see it was specifically disabled for native queries, since 0.32.10, but I actually don’t know the reason behind it:
https://github.com/metabase/metabase/pull/10196

For reference: