How can we access metabase using URL instead of IP?

How can we access metabase using URL instead of IP?

I can successfully access metabase when typing 34.22.223.23:3000 (example IP)
But when typing URL data.example.com:3000 result in ERR_CONNECTION_TIMED_OUT, Site cannot be reached
Even though I have added DNS A Record to point data.example.com to 34.22.223.23

Would appreciate your guidance on how to solve this.
Many thanks

I believe you do not need to add the port:3000 to the URL. If you already mapped the port while setting up your DNS.

DNS may not have updated yet - it can take a while to propagate.
Check if you can ping the server using the FQDN:

ping data.example.com

If that doesn’t work then it’s a problem with DNS.
If it does work, check the Metabase server is configured to use the correct address in settings.

The ping works
64 bytes from 104.28.12.236: icmp_seq=0 ttl=59 time=191.993 ms

Is the URL setting you mentioned like the screenshot below?
Even putting in that setting, the URL is still not working

Is there something else that I need to setup?
Thank you

@bobotto Exclude the port 3000 from your URL. You do not need that if you already mapped it while setting up your IP address.

DNS doesn’t map ports. Just name to IP address. Are you thinking of port forwarding?

Here are my settings (8443 as I’m using ssl):
image

Not sure what’s going on - are you using docker?

ohh no. I didn’t even notice I wrote that. Thanks for the correction. This is done on the IP address mapping.