How do we resolve 302 when invoking metabase's api/session? Please note that we have a root URL that redirects to /subpath but metabase uses <root>/metabase url

{
  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "Java(TM) SE Runtime Environment",
    "java.runtime.version": "1.8.0_144-b01",
    "java.vendor": "Oracle Corporation",
    "java.vendor.url": "http://java.oracle.com/",
    "java.version": "1.8.0_144",
    "java.vm.name": "Java HotSpot(TM) 64-Bit Server VM",
    "java.vm.version": "25.144-b01",
    "os.name": "Linux",
    "os.version": "2.6.32-504.16.2.el6.x86_64",
    "user.language": "en",
    "user.timezone": "Asia/Manila"
  },
  "metabase-info": {
    "databases": [
      "h2"
    ],
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "12.2"
      },
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
      }
    },
    "run-mode": "prod",
    "version": {
      "tag": "v0.36.0",
      "date": "2020-07-21",
      "branch": "release-0.36.x",
      "hash": "b31049f"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

Hi @becca
I’m not sure what the problem/question is, so it would help if you provided more information.
Make sure that the Site URL is correct in Admin > Settings > General.
Latest release is 0.36.4

We were able to setup metabase on a URL domain like root/metabase (on https). Then, our application URL is https://root but this automatically redirects to this domain root/numberOneSubapp (also https). When we invoke this metabase API from another URL domain root/numberTwoSubapp, we encounter a 302 error: POST /api/session. Does the /api/session endpoint have an automatic redirect, is there a way to perform the redirect from root/numberTwoSubapp to root/numberOneSubapp without causing the 302 error. We are also using node and nginx to manage the redirections within the app.

@becca I still don’t understand the problem, but it’s likely caused by bad redirects in Nginx.

Thanks. We were able to resolve it. It was an nginx issue.