How to format Summarized Expressions

I made a simple calc to shown in a painel the avg ticket from one of my products, but when i transform the value in a Gauge, the options to format the data is empty, i would like to show this data in currency format. At least, i'm tryng to input the expression round before the formula, but this command does not allow an agg functionSummarized%20Expression

Hi @Celso
Please post "Diagnostic Info" from Admin > Troubleshooting.
What Field Types are those two fields in Admin > Data Model? Something is making me think that it's caused by incorrect typing, since you are not seeing the formatting options.

As for using the round() function, that's a bug: - upvote by clicking :+1: on the first post

Hello @flamber
tks for reply so fast !
product_one_value is setted as Price(#) and clients setted as Owner(Aa)

Tks for explain about round() function! So are Devs from metabase working it ?

@Celso I would guess if you set Owner to "No semantic type", then it might work, but there's a lot of inferring going on and we've fixed some of those problems in upcoming 43.

Yes, I can see it's already being worked on - my guess is that Ariya knows exactly where the problem is and will create a fix for it soon.

@flamber even setting for "No semantic type" the bug remain.
I have tried to change the column types for other options but without succeed
There is another step ?

Tks for updating !

@Celso Post "Diagnostic Info" from Admin > Troubleshooting.

@flamber done !

@Celso I'm asking for "Diagnostic Info" from Admin > Troubleshooting. It's a large text section with details about your instance. I need you to paste it here.
I cannot reproduce the problem you are having.


  1. Upgrade to latest release:
  2. Provide the metadata output of the fields, so I know which types are being defined.
    Go to Admin > Data Model > (db) > (table) > (field) :gear: > look in the URL, which is something like .../123/general - then go to the URL /api/field/123 and provide the output here.

@flamber o god sry i undertood wrong !

"browser-info": {
"language": "pt-BR",
"platform": "Win32",
"userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.127 Safari/537.36",
"vendor": "Google Inc."
"system-info": {
"file.encoding": "UTF-8",
"": "OpenJDK Runtime Environment",
"java.runtime.version": "11.0.14+9",
"java.vendor": "Eclipse Adoptium",
"java.vendor.url": "",
"java.version": "11.0.14",
"": "OpenJDK 64-Bit Server VM",
"java.vm.version": "11.0.14+9",
"": "Linux",
"os.version": "4.14.268-205.500.amzn2.x86_64",
"user.language": "en",
"user.timezone": "GMT"
"metabase-info": {
"databases": [
"hosting-env": "unknown",
"application-database": "postgres",
"application-database-details": {
"database": {
"name": "PostgreSQL",
"version": "13.4"
"jdbc-driver": {
"name": "PostgreSQL JDBC Driver",
"version": "42.2.23"
"run-mode": "prod",
"version": {
"date": "2022-02-08",
"tag": "v0.42.0",
"branch": "release-x.42.x",
"hash": "de1264e"
"settings": {
"report-timezone": null