Installing as service on Ubuntu

Hi,

I’m trying to install Metabase (latest 0.26.2) as a service on ubuntu 14.04.5 LTS

I followed steps in this guide

when i try to start the service i got this error

Blockquote
root@cloud:~# sudo update-rc.d metabase defaults
Adding system startup for /etc/init.d/metabase …
/etc/rc0.d/K20metabase -> …/init.d/metabase
/etc/rc1.d/K20metabase -> …/init.d/metabase
/etc/rc6.d/K20metabase -> …/init.d/metabase
/etc/rc2.d/S20metabase -> …/init.d/metabase
/etc/rc3.d/S20metabase -> …/init.d/metabase
/etc/rc4.d/S20metabase -> …/init.d/metabase
/etc/rc5.d/S20metabase -> …/init.d/metabase
root@cloud:~# sudo service metabase start
Starting Metabase…
/etc/init.d/metabase: 4: /etc/default/metabaseconfig: Syntax error: newline unexpected

Googled and searched for it but nothing

am i missing something?

any help appreciated

update:
I was leaving <> in config file :zipper_mouth_face:
but still unable to configure Metabase as a service
sudo service metabase start returns no errors
tried listening on localhost,127.0.0.1,domain ip, 0.0.0.0 nothing
if i make service --status-all i get unknown status for metabase
pid 1980 is assigned to service but nothing listening on 3000
log file is empty
any idea?

Hi again,
problem solved …metabase folder had wrong permissions :face_with_head_bandage:

ty for your time
bye
Matteo