Issue with Filter using Showflake database

Need help to solve an issue with FieldFilter
Using Snowflake as a data source, after selecting VariableType as “FieldFilter”,
“Field to map to” is not showing anything in “select…” dropdown.

select *
from db_name.schema_name.table_name
where 1 = 1
[[and {{value}}]]

Any help is greatly appreciated.

Hi @grayzman
What is the Field Type set to in Admin Settings > Data Model > (database) > (table) > (column) :gear:
Field Filter only works with some types:

There are no schemas shown under /admin/datamodel/database/6

I can only see name of the database :
Current database: snowflake_db and “0 SCHEMAS” under “Find schema”

Okay, then it’s time to check the Metabase log for any signs of problems with tables/columns not being synchronized.
Maybe this issue is related?
I don’t use Snowflake, so I’m a bit lost on what’s going on.