Issue with Integrating Metabase and Microsoft365

Dear Metabase Support Team

Greetings!

I hope this email finds you well. I am writing to seek assistance regarding an issue I am facing while trying to integrate Metabase with Microsoft 365 for mail notification

I have been a long-time user of Metabase and have found it to be an incredibly useful tool for data analysis and visualization. However, I am currently encountering difficulties while attempting to integrate Metabase with microsoft365 for alerting

Specifically, I am encountering challenges when configuring the connection settings, and despite following the documentation and guidelines provided, I am unable to establish a successful connection between Metabase and the Microsoft365

I have reviewed the official documentation, community forums, and other resources to troubleshoot the issue on my own, but unfortunately, I have not been able to find a solution that resolves the problem.

I kindly request your assistance in addressing this matter. If possible, could you provide guidance or steps to ensure the seamless integration between Metabase and Microsoft365? Additionally, if there are any specific configurations or prerequisites that I may have missed, please let me know.

Thank you for your time and attention to this matter. I greatly appreciate your support and look forward to your response. If there is any additional information you require from me, please do not hesitate to ask.

You need to use the Microsoft email gateway?

I've given up trying to use MS for sending email from 3rd party applications. I use multiple BI products and it's just too much of a moving target. I just don't have the time or inclination to reconfigure umpteen servers just because MS decide to change something, yet again.
Much easier to use a 3rd party SMTP provider and add their details to your SPF record. I'm using SMTP2GO internally and with a number of customers.