It looks like HTTPS is not properly configured

I'm trying to set up https site url, but I cannot see any issues in the logs, only the UI says that:

Force all traffic to use HTTPS via a redirect, if the site URL is HTTPS
It looks like HTTPS is not properly configured

I tried looking for the validation, I probably gave up too quickly, but haven't anything which would log error details for the "not proper" setup.

The application comes up, but is not accessible via https.

Where should I look to find out what's wrong?

startup log:

2023-02-21 15:57:54,516 INFO metabase.core :: Starting Metabase in STANDALONE mode
2023-02-21 15:57:54,566 INFO metabase.server :: Launching Embedded Jetty Webserver with config: 
 {:port 3000, :ssl? true, :ssl-port 8443, :keystore "D:/backend/mb/keystore1.jks"}

Relevant environment:


Troubleshooting diagnostic info:

  "browser-info": {
    "language": "en-US",
    "platform": "Win32",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/108.0.1462.76",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "Cp1252",
    "": "OpenJDK Runtime Environment",
    "java.runtime.version": "",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "",
    "java.version": "",
    "": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "",
    "": "Windows Server 2019",
    "os.version": "10.0",
    "user.language": "en",
    "user.timezone": "Europe/Berlin"
  "metabase-info": {
    "databases": [
    "hosting-env": "unknown",
    "application-database": "h2",
    "application-database-details": {
      "database": {
        "name": "H2",
        "version": "1.4.197 (2018-03-18)"
      "jdbc-driver": {
        "name": "H2 JDBC Driver",
        "version": "1.4.197 (2018-03-18)"
    "run-mode": "prod",
    "version": {
      "date": "2023-01-27",
      "tag": "v0.45.2.1",
      "branch": "release-x.45.2.x",
      "hash": "1a59de7"
    "settings": {
      "report-timezone": null

have you checked settings->admin->general->site url?

Yes of course. I can access metabase via http and port 3000 even though the site url is set to https and port 8443.

The redirect config says it sees an invalid config, but I see no way to debug what is wrong.

For anybody who finds this: make sure the certificate you import is valid.

I made the mistake to import the .cer file directly to the keystore, instead of the pkcs12.