Login UI crashes after setting up Google SSO Login

Hey there!

We're on version running on elastic beanstalk and setup Google Auth and it was working yesterday but today there's a React UI crash happening and no-one can login if they're not already logged in.

react-dom.production.min.js:209 Error
    at _.$e (client:128:335)
    at new sp (client:227:3)
    at bq (client:246:34)
    at Oo (client:244:246)
    at Object.Po [as renderButton] (client:216:62)
    at index.esm.js:89:82
    at la (react-dom.production.min.js:211:320)
    at _c (react-dom.production.min.js:257:303)
    at t.unstable_runWithPriority (scheduler.production.min.js:19:467)
    at Yi (react-dom.production.min.js:122:325)

    in l
    in o
    in div
    in Styled(div)
    in S
    in Connect(S)
    in div
    in Styled(div)
    in div
    in Styled(div)
    in div
    in Styled(div)
    in div
    in Styled(div)
    in div
    in Styled(div)
    in tu
    in Connect(tu)
    in Hu
    in Connect(Hu)
    in Title[Connect(Hu)]
    in Unknown
    in UserIsNotAuthenticated(Component)
    in Connect(UserIsNotAuthenticated(Component))
    in MetabaseIsSetup(Connect(UserIsNotAuthenticated(Component)))
    in Connect(MetabaseIsSetup(Connect(UserIsNotAuthenticated(Component))))
    in main
    in Styled(main)
    in div
    in Styled(div)
    in div
    in Styled(div)
    in i
    in withRouter(i)
    in s
    in Unknown
    in Connect(Component)
    in Title[Connect(Component)]
    in RouterContext
    in Router
    in p
    in DragDropContextProvider
    in I

Any idea how to proceed here? Is there a way to enabled development mode or manually disable google auth login within the database?

Please upgrade to the latest version. We released a fix for this 2 days ago

1 Like

Ah, that must have been released right after I upgraded to 46.6.1 2 days ago. Will try that. Thanks!

It worked thanks!

I'm also getting same error. Can you plz tell me in detail which thing I've to upgrade. I'm using @react-oauth/google dependency of version 0.7.1 & node version 16.0.0.

You need to upgrade to the latest version