Metabase docker Upgrade failed 0.24

Metabase does not load after pulling latest docker image
Log File Gizpped

I don’t see the new version in that.

Are you trying to upgrade to 0.24.0 or 0.24.1? There was an issue with migrations on 0.24.0 + MySQL that was fixed in 0.24.1. This might result in the db lock.

java -jar metabase.jar migrate release-locks as the logs suggest + re-run the new version.

I’m not sure how to do that java command before the docker image terminates

I tried running the docker with the -it parameter,

  • sudo docker -it
  • sudo docker -it and command bash
  • sudo docker -it and command java -jar metabase.jar migrate release-lock
  • restoring the mysql-database from backup and running version v0.24.1 directly

sudo docker run
-e MB_DB_TYPE=‘mysql’
-e MB_DB_DBNAME=‘metabase’
-e MB_DB_PORT=‘my_port’
-e MB_DB_USER=‘my_user’
-e MB_DB_PASS=‘my_pass’
-e MB_DB_HOST=‘x.y.z.w’
-p 3001:3000
–name metabase
java -jar metabase.jar migrate release-lock

solved by running metabase directly using jar file on a seperate machine. and passing environment variables ONLY worked by using -D

java -jar -DMB_DB_TYPE=mysql -DMB_DB_DBNAME=metabase -DMB_DB_PORT=3306 -DMB_DB_USER=my_db_username -DMB_DB_PASS=my_db_pass -DMB_DB_HOST= metabase.jar migrate release-locks

and then the normal run
java -jar -DMB_DB_TYPE=mysql -DMB_DB_DBNAME=metabase -DMB_DB_PORT=3306 -DMB_DB_USER=my_db_username -DMB_DB_PASS=my_db_pass -DMB_DB_HOST= metabase.jar