Metabot (Slack) not working

#1

Hi All -

Do you have any other instances where Metabot isn’t working on Slack? It’s working for us, but only when we manually push it. When it’s on a scheduled time, it does not send.

Any advice?

#2

Hi @zma213
Which version of Metabase? What do you see in the log, when schedules are supposed to run?
Which database are you using as datasource? Have you tried to kill the database connection and see if it then runs the schedule?

#3
  1. 0.31.2
  2. I see nothing. Nothing appears in the logs at the time these pulses are scheduled to run.
  3. How would I kill the connection?
#4

Have you tried the new 0.32.5? Since it has a lot more logging about the schedules of pulses - and listing of jobs schedules via Admin Settings > Troubleshooting.
You would kill the connection from the database side - that’s just something that a few people reported in an issue, where the schedule would stop working after some time and then after killing the connection, the schedules would work again.

#5

Right, but I’m wonder how I would go about killing the connect?

#6

Since you don’t say which database you’re using, then I’m assuming MySQL:
https://stackoverflow.com/questions/44192418/how-to-find-mysql-process-list-and-to-kill-those-processes/44192419