Missing joined tables on `group_by` option (w/o editor)

Hi all.

I’ve been using Metabase for quite a while and I’ve been missing a feature I used to use quite frequently. While using the query builder, I used to “group by” columns of different tables (FK w/ the tables currently being queried). It had a little “drop down” menu, which made possible for me to collapse and expand all the available “group by” columns, regardless of the table (given that it had a key relation to the current table). This feature seems to be missing from my newest deploy (Docker, Beanstalk, using image provided, V0.35.4).

I’m not sure if it’s a Bug, or just a change in the business logic. I can still to the same thing, but now I have to enter the editor, and Join the tables manually, which is a bit of a pain. Maybe I’m missing something, not sure.

Any ideas?

Hi @lowercase
Which version were you using before? It sounds like it was a version before 0.33
You can find it in Summarize:

Hi @flamber thanks for replying.

It probably was before 0.33, yes. It was a version that had been deploy about 1.5yrs ago, and I decided to review my infrastructure, so I deployed a new instance this week.

I normally would do the group by directly on the “summarize” tab (without going into the editor).
So the lack of this ability is an expected behaviour of the current version?

@lowercase Okay, that was before 0.33
I don’t understand - there was no “summarize tab” before 0.33 - now there’s a Summarize button, which opens a sidebar.
Again, there has been many changes, so I would recommend that you read through the documentation, and some of the blog posts describing changes in major versions: https://www.metabase.com/blog/

Okay, so that was probably 0.34, since I used the “summarize” button that opens the side bar.
What I mean is:

This is I what I have today (this is a screenshot of the sidebar)

And what I used to have was this (I have the ability to collapse/expand) the tables that are available for “group by”, but now I have to enter the editor. (posting picture on a new post.)

But now I have to manually “join” the data, even though I already have my data models configured that establishes the connection between tables, whereas before, the available options were already there.

@lowercase Can you post “Diagnostic Info” from Admin > Troubleshooting.

  "browser-info": {
    "language": "en-US",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36 OPR/68.0.3618.173",
    "vendor": "Google Inc."
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.7+10",
    "java.vendor": "AdoptOpenJDK",
    "java.vendor.url": "https://adoptopenjdk.net/",
    "java.version": "11.0.7",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.7+10",
    "os.name": "Linux",
    "os.version": "4.14.181-140.257.amzn2.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  "metabase-info": {
    "databases": [
    "hosting-env": "elastic-beanstalk",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "11.6"
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.2.8"
    "run-mode": "prod",
    "version": {
      "date": "2020-05-28",
      "tag": "v0.35.4",
      "branch": "release-0.35.x",
      "hash": "b3080fa"
    "settings": {
      "report-timezone": "America/Sao_Paulo"

@lowercase Hmm…that’s strange. Don’t you have a scrollbar on the Summarize sidebar?

There’s no change to how linked tables work between 0.33 thru 0.35

You should see the linked tables (which you have defined via Foreign Key in Admin > Data Model) in Summarize - though not as accordion, just as a grouped list:

And in Notebook, it’s displayed as accordion: