Mongo query with Date breaks [solved: Mongo 3.0 required]

Seems like Metabase doesn’t like Date fields.
I’m using mongodb and the mac client.
An entry like {“state” : “deployed”, “thedate” : Date( 1435650003708 )}, or even {“state” : “deployed”, “thedate” : 1435650003708} returns “We couldn’t understand your question.” if trying to get the raw data.

I tried explicitly setting the field as Unix time stamp but it still breaks.
Also, changing time zone didn’t get.

If you’re on the Mac app, could you open up the Console program and see if MB dumps any additional information about why the query is throwing an error?

2015-12-08 3:49:47.962 PM Metabase[41265]: [ERROR] metabase.driver :: Query failure: Command failed with error 15999: ‘exception: invalid operator ‘$dateToString’’ on server localhost:27017. The full response is { “errmsg” : “exception: invalid operator ‘$dateToString’”, “code” : 15999, “ok” : 0.0 }

opened an issue for you at https://github.com/metabase/metabase/issues/1655

1 Like

Looks like the problem was that I was running mongo 2.6.
Mongo 3.0 is required for Metabase