MongoDB not showing up on options list

I ran java -jar metabase.jar on an AWS server with a MongoDB instance running locally. MongoDB doesn’t seem to be on the database options list. What can I look into to find the source of the error? I am not getting any error messages on Metabase startup.

can you take a screenshot of what you see in database addition screen?

that sounds very strange. Also what AMI are you using, which version of MB and which browser version?

The database addition screen just lists H2, I’m using the default Ubuntu 16.04 image, the latest Metabase and Chrome 54.0.2840.100 (64-bit).

can you take a screenshot. this is odd, and I’ve never personally ran across it. curious what it looks like and how to reproduce.

what jre are you using?

I think I’ve seen this happen before on an early openjdk 9 build.

Ah, I’ll try another build.

Is that you confirming that you’re on openjdk 9?

If you’re seeing it on another JRE, we’d really really like to know.

That was indeed the issue, it was because of OpenJRE v9, I downgraded to 8 and it worked. Thanks!

1 Like