New installation reports postgre & mysql names do not exist

At a Docker volume on I've SSH installed newest Metabase. Setup was going well in my browser until I tried connecting to a running postgre database. There is no data, no tables. But it is named and has an internal IP address and is running.
SAVE produces "wrong password" or "cannot connect" or "cannot find the name of my postgre installation.

I don't know the logic Metabase is using to report failures.
Such as if "Looks like the database name is incorrect." means that it accepted my username, password, internal host ip & then could not find the named.
Log shows
2022-07-13 14:20:29.138 UTC [1] LOG: database system is ready to accept connections
2022-07-13 15:20:13.509 UTC [110] FATAL: database "storiespostsgre" does not exist

I tried updating the name twice but Metabase insists it can"t find the database. Same with a running mysql install.

I connect to these databases in this docker Ubuntu 20.4 disk immediately with other application setups.

Without SSH there ought to be an immediate connection as other apps that have referenced these database installs prove.

I found this on Metabase install on Linodes

Do all of these extra commands need to be run as well just to get the metabase latest running in a Linodes volumr?

That guide is extremely old and it's not recommended. Please follow

the error you're seeing is because there's no database named "storiespostsgre", log in to the database and create that DB if needed

1 Like