New Subscriptions to Email / Slack are not working post upgrade to Metabase v0.49.8

Since our last metabase upgrade to v0.49.8 (from v0.48.10), we are not getting automated email slack alerts for subscriptions. Though manual triggering (Send to Email Now and Send to Slack now) is working as expected.

We also noticed that the subscriptions which were created pre upgrade are working, new subscriptions are not working anymore.

Metabase version -

You're on version v0.49.8
Built on 2024-05-02

Diagnostic Info -

{
  "browser-info": {
    "language": "en-GB",
    "platform": "MacIntel",
    "userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36",
    "vendor": "Google Inc."
  },
  "system-info": {
    "file.encoding": "UTF-8",
    "java.runtime.name": "OpenJDK Runtime Environment",
    "java.runtime.version": "11.0.23+9",
    "java.vendor": "Eclipse Adoptium",
    "java.vendor.url": "https://adoptium.net/",
    "java.version": "11.0.23",
    "java.vm.name": "OpenJDK 64-Bit Server VM",
    "java.vm.version": "11.0.23+9",
    "os.name": "Linux",
    "os.version": "6.1.84-99.169.amzn2023.x86_64",
    "user.language": "en",
    "user.timezone": "GMT"
  },
  "metabase-info": {
    "databases": [
      "postgres",
      "redshift",
      "snowflake",
      "h2",
      "sqlserver"
    ],
    "hosting-env": "unknown",
    "application-database": "postgres",
    "application-database-details": {
      "database": {
        "name": "PostgreSQL",
        "version": "13.13"
      },
      "jdbc-driver": {
        "name": "PostgreSQL JDBC Driver",
        "version": "42.7.2"
      }
    },
    "run-mode": "prod",
    "version": {
      "date": "2024-05-02",
      "tag": "v0.49.8",
      "hash": "38cb850"
    },
    "settings": {
      "report-timezone": null
    }
  }
}

I tried this out in 49.8 and 49.9 and new subscription I set up come through. Can you clarify what you mean when you say they don't work?

Do they completely fail to deliver or the subscriptions come through but the contents vary from what's expected? Do you see anything in the logs?