No advanced metrics under "view" when creating question

When trying to create a new question to query my database I get limited option under “VIEW”. The options that I receive are: “Raw data”, “Count of rows”, “Number of distinct values of …”, “Cumulative count of rows” and “Custom Expression”. There is no option to expand advanced metrics, nor are they listed. Is there a way to trigger these options?

This can happen if the table you’ve selected has no fields that are marked as Number in the Data Model section of the Admin Panel. Metabase attempts to assign metadata attributes like this automatically, but sometimes it guesses wrong. So if you’re trying to do Sum, Average, etc. and they’re not showing up, go check that table in the data model and see what Type all the fields have assigned to them.

So just by assigning a single field as “numbers” in the table in the data model, will that trigger that advanced metrics options?

Yes, you should see all of the aggregation options in the “View” menu in the GUI query builder if at least one field in your selected table is of the type Number. Have you tried that?

I have tried that in the data model (changing 1 or multiple fields to “Numbers”) and there is no change to the “View” menu options.

Hmm, sorry for the hassle. Could you give me more details about your setup, please?

  • database type
  • Metabase version
  • metadata for the field you’re trying to aggregate
  • browser and OS
  • deployment environment (Heroku, elastic beanstalk, Mac app, etc.)
1 Like

database type: Postgre SQL
metabase version: v0.23.1
metadata: visibility-everywhere, type-category
browser: google chrome
os: macos sierra 10.12.4
deployment environment: heroku