Not able to add the Question to the Dashboard [There was a problem displaying this chart]

I am not able to add this question to the dashboard, everything seems fine at the question level -

when I try to add to the dashboard, this is the error I get -

1 Like

@maz any inputs from you will be appreciated.

Hi, you probably checked that already but as you have filters on question level, you need to have those filters on dashboard level as well, otherwise an error message appears?
Hope you can sort it out, cheers, Eva

thanks @EvaS for the reply. I have the same filters that are being used by an other Question on the same dashboard, it’s just doesn’t let me display the Question on the dashboard, I tried displaying the question on a blank dashboard and that didn’t work either. Do you think this has something to do with an aggregate function on the Y-axis?

still no success, the dashboard is just doesn’t seem to work for any query.

Same thing start to happen here. Any thoughts on how to solve it?

On the logs console I have the following error:

Oct 30 11:59:39 WARN metabase.query-processor :: Query failure: Failed to resolve fields: too many iterations.

@hky404: same error on your side?

Hi, I got that once when I tried to show too many data (mainly too many data points on the x axis). Does it work when you limit the data points shown on the x axis? Does not solve the problem though, would be a workaround …

In my case I found out what was happening. On the admin panel > data model, I had choosen Do not Include in a column that was being used in my metabase questions.

The error message was not exactly pointing to this solution so maybe there could be a small improvement there for it to be easier to identify.

Thanks for the answerr @EvaS!