Notebook Editor, unable to change displayed language

Hi,
We’re using Metabase in France, is it possible to change the language of date labels without SQL Editor ?

Example : Summarize by month, I’d like to have french labels :

Thanks for your help !

Hi @KentVchr
Yes, Metabase will change interface language depending on the users browser setting (in Firefox it’s “Preferred language for displaying websites”).
There’s work being done to have a setting available in Metabase - might be part of 0.34.0

Hi @flamber ,
Thanks for your reply.
The “Preferred language for displaying websites” works for the global Metabase interface but not for my issue, labels are still in english.

@KentVchr
Ohhh, now I see. That looks like a bug. But I’m having difficulties reproducing what you see. When I group by “Month”, then I get “January, 2019” (aka “Month name, year”), but when I group by “Month of Year”, then it just shows month name and in French “janvier”.
But it seems like the bug is in 0.33.5 - it shows correctly in 0.33.4
Workaround is to change visualization Settings > Axes > X-axis scale = Ordinal.

I’ve created an issue:

1 Like

Thanks for the report @flamber !
Have a nice day.